GrayFace MM7 Patch v2.5.7 [Mar 4, 2022]

The role-playing games (I-X) that started it all and the various spin-offs (including Dark Messiah).
rygaar
Leprechaun
Leprechaun
Posts: 5
Joined: 24 Aug 2022

Re: GrayFace MM7 Patch v2.5.7 [Mar 4, 2022]

Unread postby rygaar » Aug 26 2022, 1:21

Thanks Tomsod. Those hooks fixed the crash issue and gave me a further idea.

I currently have three monitors hooked up, with my desktop extended to each. Two have the same resolution, one a lower resolution. I decided to disable the lower resolution monitor and try again. This works, including with mouselook.

So probably a bug related to multiple monitors / different resolutions.

Regardless, now I have a work around!

Thank your for your help. Much appreciated!

Tomsod
Scout
Scout
Posts: 153
Joined: 31 Jul 2020

Re: GrayFace MM7 Patch v2.5.7 [Mar 4, 2022]

Unread postby Tomsod » Aug 26 2022, 1:26

You're welcome. If you can, check this thread again in a while: when Grayface appears, he might need your help to fix this the proper way.

rygaar
Leprechaun
Leprechaun
Posts: 5
Joined: 24 Aug 2022

Re: GrayFace MM7 Patch v2.5.7 [Mar 4, 2022]

Unread postby rygaar » Aug 26 2022, 2:59

Will do. Thanks again!

rotalihinna
Leprechaun
Leprechaun
Posts: 33
Joined: 18 Dec 2018

Re: GrayFace MM7 Patch v2.5.7 [Mar 4, 2022]

Unread postby rotalihinna » Aug 28 2022, 17:22

I'm just so used to the map being on the top right from playing MM6 for so long. I love the new interface with GrayFace's patch, but is there a way to change the location of things, so I can move the automap from the bottom to the top (or at least the center)?

rotalihinna
Leprechaun
Leprechaun
Posts: 33
Joined: 18 Dec 2018

Re: GrayFace MM7 Patch v2.5.7 [Mar 4, 2022]

Unread postby rotalihinna » Sep 12 2022, 17:06

Does the "Of Recovery" enchantment not work in MM7?

The Elven Chainmail doesn't seem to affect recovery rate. Plus, I created an 'of recovery' ring in an editor, and it doesn't affect RR either.

Mareneusz002
Leprechaun
Leprechaun
Posts: 29
Joined: 29 Mar 2019

Re: GrayFace MM7 Patch v2.5.7 [Mar 4, 2022]

Unread postby Mareneusz002 » Sep 14 2022, 22:18

EDIT: nevermind
Last edited by Mareneusz002 on Sep 15 2022, 0:01, edited 2 times in total.

Eksekk
Scout
Scout
Posts: 170
Joined: 19 Jul 2016

Re: GrayFace MM7 Patch v2.5.7 [Mar 4, 2022]

Unread postby Eksekk » Sep 14 2022, 22:50

It's because you installed Grayface patch with some options and there are files 00 *.lod and 01 *.lod overriding the default archives. The file that causes this bug in particular is "00 patch.icons.lod". To fix it, put your modified files in new archive like "mod.icons.lod". Easiest way to create proper archive is open icons.lod, make sure nothing is selected and use option "export selection to new archive".

Mareneusz002
Leprechaun
Leprechaun
Posts: 29
Joined: 29 Mar 2019

Re: GrayFace MM7 Patch v2.5.7 [Mar 4, 2022]

Unread postby Mareneusz002 » Sep 14 2022, 23:55

Eksekk wrote: Sep 14 2022, 22:50 It's because you installed Grayface patch with some options and there are files 00 *.lod and 01 *.lod overriding the default archives. The file that causes this bug in particular is "00 patch.icons.lod". To fix it, put your modified files in new archive like "mod.icons.lod". Easiest way to create proper archive is open icons.lod, make sure nothing is selected and use option "export selection to new archive".

Thanks again man!!! you are saving my life

it was my fault... i have probably accidently put the PC10bod into 00 patch.icons.lod
i have just deleted it now and all works :P

yea i was making custom images of portaits, bodys etc and seems like 1 of them went to wrong place ^^

thanks!!!

Mareneusz002
Leprechaun
Leprechaun
Posts: 29
Joined: 29 Mar 2019

Re: GrayFace MM7 Patch v2.5.7 [Mar 4, 2022]

Unread postby Mareneusz002 » Sep 22 2022, 23:58

Eksekk wrote: Sep 14 2022, 22:50 It's because you installed Grayface patch with some options and there are files 00 *.lod and 01 *.lod overriding the default archives. The file that causes this bug in particular is "00 patch.icons.lod". To fix it, put your modified files in new archive like "mod.icons.lod". Easiest way to create proper archive is open icons.lod, make sure nothing is selected and use option "export selection to new archive".

This was surely my fault, but now i have some bugs, not sure if its my fault:

the "animations" at every shop, guild, taverns, etc. are now ultra lagged (it looks like image now. not the animation)
animations i mean whenever you go to some shop, so theres some animation/video. the .smk files

this bug is only at GrayFace MM7 Patch v2.5.7
and at 2.4 not

in first case, like you said, yes i have installed version 2.5.7 with some options (had version 2.4 and installed to 2.5.7)
but now, i have disabled all options when installing from version 2.4 to 2.5.7





other error is some message when i start new game (MM7)
and only if i started game with mm7.exe in game directory, but when i run shortcut "Might and Magic® VII" so theres no error

im almost sure i havnt changed anything in that MM7 folder

the message:











Data\new.lod inside looks very suspicious Xd
















is there some solution to fix it?
or maybe i will just try to reinstall game and install fresh Grayface patch, but will need to find the CD :P


thanks!!

Eksekk
Scout
Scout
Posts: 170
Joined: 19 Jul 2016

Re: GrayFace MM7 Patch v2.5.7 [Mar 4, 2022]

Unread postby Eksekk » Sep 24 2022, 7:19

I can only see 1 change which could cause these lags:

Code: Select all

[+] House animation is no longer restarted when you click any topic. Add FixHouseAnimationRestart=0 to INI to disable this change.
It's from Grayface patch 2.5. EDIT: You can also try turning the change off. Add the mentioned code to ini file in section [Settings] in new line.

Can you test what is the most recent version of patch which causes these issues? You can use binary search to minimize number of installs (check the middle version - if it has bug, check middle of upper not included part, if it doesn't, check middle of lower not included version. Continue until you would have to move to already checked version. All versions of patches are here.

And make sure game isn't installed in Program Files folder, windows can and will screw with access to files there. This could cause both of your problems, especially second. If it is in there, move it out (but not in a subfolder of Program Files!). Check if it's working.

Mareneusz002
Leprechaun
Leprechaun
Posts: 29
Joined: 29 Mar 2019

Re: GrayFace MM7 Patch v2.5.7 [Mar 4, 2022]

Unread postby Mareneusz002 » Sep 25 2022, 0:33

Eksekk wrote: Sep 24 2022, 7:19 I can only see 1 change which could cause these lags:

Code: Select all

[+] House animation is no longer restarted when you click any topic. Add FixHouseAnimationRestart=0 to INI to disable this change.
It's from Grayface patch 2.5. EDIT: You can also try turning the change off. Add the mentioned code to ini file in section [Settings] in new line.

Can you test what is the most recent version of patch which causes these issues? You can use binary search to minimize number of installs (check the middle version - if it has bug, check middle of upper not included part, if it doesn't, check middle of lower not included version. Continue until you would have to move to already checked version. All versions of patches are here.

And make sure game isn't installed in Program Files folder, windows can and will screw with access to files there. This could cause both of your problems, especially second. If it is in there, move it out (but not in a subfolder of Program Files!). Check if it's working.

yes, i tested it, its version 2.5 which made the lag
i have turned it off and now its all good
thanks!

but i know why it was lagging.
because i play MM7 with vanilla graphic. when i installed fresh mm7 with grayface patch, so there was 2 black bars at left and right which i dont like, so i was trying to make game full screen
so i changed BorderlessFullscreen=1
to 0

so i got MM7 vanilla graphic, but the animations in shops were lagged

so the solutions to fix it is like you said, FixHouseAnimationRestart=0
or change mm7 properties to "Run in 640 x 480 resolution" which also works good for animations and vanilla graphic

i havnt played the new graphic yet (hardware mode), because i like old style :D but i will probably give it a try in future






the second error, i just reinstalled the game and now its all good
and the screenshot of new.lod is wrong xdd
i have opened it with Scite instead with MMarchive :applause: thats why it looks crazy Xd


thanks!!


Return to “Might and Magic”

Who is online

Users browsing this forum: No registered users and 22 guests