How to get the console to work in HOF

The new Heroes games produced by Ubisoft. Please specify which game you are referring to in your post.

Moderator: Moderators

User avatar
Sgt_BFG
Pixie
Pixie
Posts: 126
Joined: 06 Jan 2006
Location: Vantaa, Finland

Postby Sgt_BFG » Oct 29 2007, 13:30

Angelspit wrote:Still worth a sticky?


Some people might find it useful later.

User avatar
frozd
Big Nose
Big Nose
Posts: 111
Joined: 06 Jan 2006

Postby frozd » Jul 11 2009, 15:17

Hi guys, I just bought the gold edition of homm5 and I have a bit of a problem. I tried to get the console to work, but the game it self didn't create my game profile in My Documents folder. Anyone had a similar problem?

User avatar
shone976
Leprechaun
Leprechaun
Posts: 24
Joined: 27 Jun 2006
Location: Serbian Dungeon

After all that inputs in cfg files...

Postby shone976 » Oct 11 2009, 12:16

...you have to type in "enable_cheats" (without quotes) in console each time you play game and all will work.

hope that helps...

aceymi
Leprechaun
Leprechaun
Posts: 2
Joined: 10 Jan 2010

No luck with Vista

Postby aceymi » Jan 10 2010, 22:04

I have a laptop with Vista and have been unable to install the console following directions from this forum and others. Could someone help me out? Please make the directions as simple as possible as I am not ver computer knowledgable. Thanks

bkknight2602
Peasant
Peasant
Posts: 92
Joined: 23 May 2010
Location: Texas

Re: How to get the console to work in HOF

Postby bkknight2602 » Jan 17 2011, 19:43

I'm going to ask hw to get the console to be enabled with my system. Let me first say I have a desktop runnng Vista with Heroes 5 Epic collection AND THE DEBUG CONSOLE WORKS FINE.
I purchased a laptop (Alienware M17X) running Win7 and installed the same Heroes 5 Epic collection. After that I edited the autoexec.cfg file and copied that file into the C:\Users\My Name\Documents\My Games\Heroes of Might and Magic V - Tribes of the East\Profiles\My Name. This is where the Saves folder exists. I then edited the input_a2.cfg with bind show_console '`' in the \\Obsolete....... area. This input_a2.cfg was also copied to the game profile folder as well as the default_profile folder.
Having accomplished these small tasks, the console does not appear when the ` key is depressed.
Any suggestons or help would be appreciated.

Sir_Toejam wrote:for some reason that escapes me, Nival created an entirely new profile directory and files that contain exactly the same friggin data as the original version, but with different names.

*sigh*

I guess it was too much to ask that they assume we would want the same setup for the expansion as for the original.

so here's what you have to do (if it's not already working for you)...

in addition to modifying the input_a1.cfg file in your new profile directory, which should look something like this:

C:\Documents and Settings\Tom\My Documents\My Games\Heroes of Might and Magic V\Hammers of Fate\Profiles\Toejammer

you need to go to the directory for the game itself, and the profile directory THERE:

E:\Heroes of Might and Magic V\profiles

and find the file:

autoexec_a1.cfg

add the same line you normally would add to the autoexec.cfg for the normal version:

setvar dev_console_password = schwinge-des-todes

at the very bottom.

copy that file to your personal profile directory for HOF (the documents and settings one).

done.

that works fine for me.

NOTE:

you can get the console to pop down simply by adding the binding keys to the input_a1.cfg file, but the cheat codes themselves will not work unless you add the autoexec_a1.cfg file to your HOF profiles directory.

for those that have forgotten what to do with your input.cfg file (in this case input_a1.cfg):

go to the line starting:

// obsolete, but strictly need for compability with some interfaces

and add the line:

bind show_console '`'

to the end of that section.

so it should look like this:

// obsolete, but strictly need for compability with some interfaces
bind close_window 'ESC'
bind confirm_action 'ENTER'
bind confirm_action 'NUM_ENTER'
bind show_console '`'

or, if you have the additional section with the debug keys listed, it would look like this:

// obsolete, but strictly need for compability with some interfaces
bind close_window 'ESC'
bind confirm_action 'ENTER'
bind confirm_action 'NUM_ENTER'

//debug keys
bind show_console '`'

zookman
Leprechaun
Leprechaun
Posts: 3
Joined: 08 Aug 2014

Postby zookman » Aug 8 2014, 21:26

ive done what it says to but it wont save the file after i edit it ...


Return to “Heroes V-VI”

Who is online

Users browsing this forum: Google [Bot] and 5 guests