M&M IX bogging badly in XP.

The role-playing games (I-X) that started it all and the various spin-offs (including Dark Messiah).

Moderator: Moderators

Spidercider
Leprechaun
Leprechaun
Posts: 5
Joined: 30 Apr 2010

M&M IX bogging badly in XP.

Postby Spidercider » Apr 30 2010, 3:33

I'm having trouble figuring out why M&M IX is saving games, opening main menu and opening inventory incredibly slowly. The game will play just fine, but is terribly slow when opening main menu, opening inventory, or using NPC inventory such as buying and selling, etc.

I have tried running the games in ALL compatibility modes and have updated to V1.2. Nothing worked. I looked for an XP patch for the game but couldn't find one. Any help greatly appreciated. thanks in advance.......

jorgamesh
Leprechaun
Leprechaun
Posts: 20
Joined: 13 Dec 2009
Location: jorgamesh

Postby jorgamesh » Apr 30 2010, 4:59

try to apply latest unofficial patch v1.3a

http://telp.org/mm9/

Spidercider
Leprechaun
Leprechaun
Posts: 5
Joined: 30 Apr 2010

Postby Spidercider » May 1 2010, 0:26

o.k. thank you Jorgamesh. I'll give that a try. I was just at that site yesterday and haven't yet installed 1.3 or 1.3a. So, hopefully, that will help. Let you know...

Spidercider
Leprechaun
Leprechaun
Posts: 5
Joined: 30 Apr 2010

Postby Spidercider » May 1 2010, 2:21

Well, nope. That didn't help. I even disabled all advanced graphics and tried running the game in 640-480 resolution. I have also exhausted every compatibility mode. Still takes an average of 15 to 20 seconds just to open up my inventory or escape to main menu. The only thing that I have found that could possibly help is that the main exe file still shows that it's V1.0.0.2, even after running all the updates. When I installed V1.2, I did get this error message:
"Missing or invalid registry/INI entry"

But, wasn't sure what to do about it. I hit o.k. and ran the update. It ran and seemed to update everything, but then I would think that the exe file should say v1.2 or v1.3a if it, in fact, did update.

I ran both patches from my Might and Magic IX folder.

zalunaya
Leprechaun
Leprechaun
Posts: 38
Joined: 15 May 2008

Postby zalunaya » May 1 2010, 4:19


Spidercider
Leprechaun
Leprechaun
Posts: 5
Joined: 30 Apr 2010

Cshell.dll patch

Postby Spidercider » May 2 2010, 4:00

Zalunaya,

Wow, no way! I don't know how you found that, but who cares! I installed it in less than a minute and tried it... and it works like a charm. Took nearly ALL of the waiting time out. From 15 to 20 seconds to less than 1 second to load up. :D

Nice find Zalunaya and THANKS again! Thanks too Jorgamesh.


Return to “Might and Magic”

Who is online

Users browsing this forum: No registered users and 14 guests