Welcome Visitor [sign up] news downloads walkthroughs forums about  
Welcome to Celestial Heavens! - all things Might and Magic
sections
 
my account
Username
Password
  Forgot password?
  Home
  Sign up
  Submit Map
  Contact Us
 
my account
  Academy Guide 3.1
  Artifacts
  Creature Abilities
  First Month Utopia
  Hero Screen
  Inferno TotE Guide
  New Sylvan Strategy
  Screenshots
  Skill Wheel
  Spells
  Story
  Unofficial Guide
 
my account
  Hammers of Fate
  Tribes of the East
 
my account
  Academy
  Dungeon
  Fortress
  Haven
  Inferno
  Necropolis
  Sylvan
 
my account
  Maps
  Mods
  Patches
 
my account
  Forums
  Equilibris Mod
  LotA
  Thunder Maps
  Wake of Gods Mod
  More Links
 
my account
  Interviews
  Map Reviews
  Special Features
 
my account
H7: Would you prefer 2D or 3D townscreens?
2D
3D
I don't care.
game selector


Features  → Patches

by Kalah

Celestial Heavens Patches Page

Here we have assembled a collection of patches for your HoMM and Might & Magic games.

Heroes of Might & Magic: Some games need more patching than others; this was especially true with Heroes IV and V. Still, we have put the older patches up for you for download. The Ubisoft-produced games have large patches and the pages below give you directions to them.

  • Dark Messiah of Might & Magic - there are two patches for Dark Messiah; 1.1 and 1.2. Both are available in either international/US or German versions.
Comments

Kalah at 2012-08-21 20:42 wrote:
I have created a separate page for the H5 patches. :)

Kalah at 2011-11-08 17:03 wrote:
Page updated with something from the Ubi server for older games. I will update more when .exe files for H6 are released.
RomeLedak at 2010-03-07 08:10 wrote:
I am having the same problem as wdevil, I got 1.1 then it said 1.2 and 1.3 obsolete so I went 1.4 then 1.41 1.5 and 1.6 but my campaign wont work, since it only lets me go to the screen where there is a single player, dual, or 3x3, i click on them but nothing happens. Please help, thanks.

Also I don't know if this makes a difference but when I get on, the game says it is version 1.1 so I tried re-downloading 1.4-1.6 but it said I already had those downloaded, thanks again.
Edited on Sun, Mar 07 2010, 03:20 by RomeLedak

Queen Hera at 2010-02-03 11:00 wrote:
Managed to get the MM6 patch from another site.

Queen Hera at 2010-02-03 08:17 wrote:
Re MM6 Patch
When I tried to download this patch i got a warning message: "Trojan Horse Program"... has any1 else had this happen?

winterfate at 2008-07-19 02:01 wrote:
*notices text about no hotlinking*

WEAK!! :sad:

Bah! Whatever...
This is the pic I tried to show Asheera last post... :)

*ahem* You mean this pipeline! :down: ;)

http://i175.photobucket.com/albums/w146/darrin88/Pipes.jpg

darknessfood at 2008-07-18 17:24 wrote:
:lolu: you gotta love that!

ThunderTitan at 2008-07-18 07:21 wrote:
yes, linking to a img on a site that doesn't allow hotlinking is indeed a great idea.

winterfate at 2008-07-17 23:23 wrote:
@Asheera: No. You must mean this one...:down:

http://ian-albert.com/misc/gamemaps/super_mario_bros/full/mario-underground-transition.gif

;)

Asheera at 2008-07-17 12:50 wrote:
I heard it's on the pipeline. Now where is that stupid pipeline... http://i289.photobucket.com/albums/ll221/Asheera_Moonblood/Long_Pipeline.jpg

Angelspit at 2008-07-17 12:27 wrote:
I heard it's on the pipeline. Now where is that stupid pipeline...
espen13 at 2008-07-17 12:25 wrote:
no toe patch had come yet
wdevil at 2008-04-24 16:03 wrote:
Can anyone help me?

i installed all the patches 1.1 to 1.5 (1.6 says i don't have HMMV installed, why is this?) but then when i open the game it still says version 1.0, and i can't even play the campaign mode, since it only lets me go to the screen where there is a single player, dual, or 3x3, i click on them but nothing happens...

would apreciate someone answering. thank you

Ravenheart87 at 2008-01-29 14:38 wrote:
The expansions have different patches. If it makes everything clearer:
Heroes5 is v1.0
Hammers of Fate is v2.0
Tribes of the East is v3.0

You only need to patch the version you ar playing with. Tribes has no patch yet.
achernar at 2008-01-29 14:32 wrote:
Question: If i buy the expansion, do I still need to patch the original game to latest patch? Or the expansion already cover it up?

Guarderman at 2007-12-25 07:11 wrote:
No, not yet
gelu66222 at 2007-12-25 05:25 wrote:
hey is there a tribes of the east patch?

ebxhomm at 2007-08-25 18:37 wrote:
FINALLY! I can find a place to download MM6-8 patches. Thank you very much CH.

From The Daemons (Light and Lighter )

Note: You must be logged in to post comments.

Copyright 1999-2015 Celestial Heavens. All rights reserved.
site statistics