Ridiculous graphical lag in Heroes 4

The old Heroes games developed by New World Computing. Please specify which game you are referring to in your post.

Moderator: Moderators

User avatar
Senatorial
Leprechaun
Leprechaun
Posts: 9
Joined: 28 Feb 2013

Ridiculous graphical lag in Heroes 4

Postby Senatorial » Aug 23 2013, 20:50

I am having serious graphical problems running HoMM4 WoW. My comp is a gaming notebook running Windows 7 64-bit. The game is in compatibility mode for Windows 98/ME.

When I load up any map, everything begins to lag very quickly. I can barely last a turn until my cursor and screen drag so much the game is nearly unplayable.

If I run the game with no compatibility on, there's a different problem...half of the time, the game doesn't render new screens (like when fliping through a spellbook) until I run the mouse cursor all over it, when it renders the graphics piece-by-piece.

Has anyone else had the same problems or know how to get the game working under W7 64? Thanks!

User avatar
Xdarkon
Pixie
Pixie
Posts: 131
Joined: 28 Apr 2013
Location: Andover, Hampshire

Postby Xdarkon » Aug 24 2013, 13:55

Mhmmm, I get that on my 32-bit windows 7 Notebook... But only a few hours of gameplay. I am afraid I can't help you, sorry

User avatar
Pol
Admin
Admin
Posts: 9227
Joined: 29 Nov 2005
Location: IN SOMNIS VERITAS
Contact:

Postby Pol » Aug 25 2013, 6:10

Before playing the game disable graphic acceleration from windows control panel.
"We made it!"
The Archives | Collection of H3&WoG files | Older albeit still useful | CH Downloads
PC Specs: A10-7850K, FM2A88X+K, 16GB-1600, SSD-MLC-G3, 1TB-HDD-G3, MAYA44, SP10 500W Be Quiet


Return to “Heroes I-IV”

Who is online

Users browsing this forum: No registered users and 7 guests