Computer Question

Light-hearted discussions, forum games and anything that doesn't fit into the other forums.

Moderators: Moderators, Celestial Heavens Staff

User avatar
ByteBandit
Archangel
Archangel
Posts: 1437
Joined: 27 Nov 2005

Computer Question

Postby ByteBandit » Sep 16 2009, 22:51

How come I can run all my HoMM games, I - IV, but my computer crashes all the way to start with every HoMM map editor I have? It never did it before, but now it does it all the time. Can someone help me resolve this head scratching problem? Could it be a virus? My AVG and Spybot says all is clean. Now what should I do?

User avatar
darknessfood
Round Table Hero
Round Table Hero
Posts: 4009
Joined: 02 Jul 2007
Location: Netherlands
Contact:

Postby darknessfood » Sep 17 2009, 7:29

Which version of windows do you use? Did you try and back up your created maps and reinstall them?
You can either agree with me, or be wrong...

User avatar
ByteBandit
Archangel
Archangel
Posts: 1437
Joined: 27 Nov 2005

Postby ByteBandit » Sep 17 2009, 8:33

I have XP. All my maps are and have been backed up just in case something like this did happen. I don't know if it's a memory problem or what. And can someone hijack memory? Not much of an expert when it comes to viruses and the like.

User avatar
darknessfood
Round Table Hero
Round Table Hero
Posts: 4009
Joined: 02 Jul 2007
Location: Netherlands
Contact:

Postby darknessfood » Sep 17 2009, 9:41

No, you can only hijack memory, only things that could be hijacked are software, and such. Did you try the reinstall thing? What are your computer stats?
You can either agree with me, or be wrong...

User avatar
ByteBandit
Archangel
Archangel
Posts: 1437
Joined: 27 Nov 2005

Postby ByteBandit » Sep 17 2009, 20:47

My CPU speed is 1.5 hz My memory is 224 MB and 40 GB hard drive. It's a laptop and I'm wondering if changing my power settings to Desktop would change the drivers. On laptop, it says the drivers shut down after 30 minutes, but on desktop they never shut down.

User avatar
darknessfood
Round Table Hero
Round Table Hero
Posts: 4009
Joined: 02 Jul 2007
Location: Netherlands
Contact:

Postby darknessfood » Sep 18 2009, 0:54

Well, purhaps upgradinf memory should help. Buy a new laptop (upgrading is expensive) and run windo's XP should do the trick. Did a reinstall help?
You can either agree with me, or be wrong...

User avatar
Shyranis
Assassin
Assassin
Posts: 274
Joined: 27 Jul 2009

Postby Shyranis » Sep 18 2009, 13:55

Running Service Pack 3? That takes up a bit more memory.
Youtube has terminated my account without reason.

Please express why it should be reinstated on Twitter.

User avatar
darknessfood
Round Table Hero
Round Table Hero
Posts: 4009
Joined: 02 Jul 2007
Location: Netherlands
Contact:

Postby darknessfood » Sep 18 2009, 14:41

Perhaps it uses up like 10mb more. So I don't think that is the case?
You can either agree with me, or be wrong...

User avatar
ByteBandit
Archangel
Archangel
Posts: 1437
Joined: 27 Nov 2005

Postby ByteBandit » Sep 19 2009, 20:03

I changed the settings in the control panel on the power schemes from 30 minutes to 4 hours with the drivers in laptop mode. And so far after running H3 WoG Map Editor, I went over 45 minutes before manually shutting it off, which means, so far, I think, that was the problem. Before, it would shut my computer down completely around 30 minutes of use. But going over 45 minutes, that's a record for this laptop as of late. When I upgraded Spybot around 8 months ago, it changed all my settings. And that was one I forgot to change back.
See, I never use a battery on my laptop, it is always plugged in, so I can use the drivers without worry of draining power usage. More testing will be needed for my verification, but at least I'm going in the right direction I think. Other opinions by everyone is welcome. And a big thanks to those of you who helped.

EDIT;
Now it goes an hour then crashes. Well, with Salamandres WoG patch anyway. Guess you gotta have a lot of something to run it. No maps from me with his patch. Sorry.

User avatar
MistWeaver
Wraith
Wraith
Posts: 1277
Joined: 28 Feb 2006
Location: Citadel of Frosts

Postby MistWeaver » Oct 4 2009, 10:57

Well, first of all it cant be insufficient memory problem if all editors are crashing and there is enough space for your pagefile on corresponding drive (C: be default) and its not manually limited. It should be able to grow not less than to 2 gigs.

Question 1: What kind of crash ? Only editor or whole OS? Is it freeze, BSOD or reboot ? Is there some crash info ?

Question 2: Does any other software causing similar behavior ?

User avatar
Pol
Admin
Admin
Posts: 9634
Joined: 29 Nov 2005
Location: IN SOMNIS VERITAS
Contact:

Postby Pol » Oct 4 2009, 13:20

Hi :D

Can you just reinstall WoG somewhere else and try it from here? It may not be memory on your notebook just damaged/altered wog archive files.

Surprisingly you may be able to play a game with them but not use the editor. * Reason could be that editor update went wrong sometimes in the past, so you're now having an older version of it.
"We made it!"
The Archives | Collection of H3&WoG files | Older albeit still useful | CH Downloads
PC Specs: A10-7850K, FM2A88X+K, 16GB-1600, SSD-MLC-G3, 1TB-HDD-G3, MAYA44, SP10 500W Be Quiet

User avatar
MistWeaver
Wraith
Wraith
Posts: 1277
Joined: 28 Feb 2006
Location: Citadel of Frosts

Postby MistWeaver » Oct 4 2009, 15:16

Pol wrote:...
damaged/altered wog archive files.

Surprisingly you may be able to play a game with them but not use the editor. * Reason could be that editor update went wrong sometimes in the past, so you're now having an older version of it.
what about other 3 editors ? Thats a hell of coincidence if all 4 games somehow got their files damaged enough to broke editor, but nothing else. I bet on system-wide issue.


Return to “Campfire”

Who is online

Users browsing this forum: No registered users and 13 guests