New mod and maps

Official forum of the Wake of Gods mod to Heroes of Might and Magic III.

Moderator: Moderators

User avatar
chaos_dragon2
Leprechaun
Leprechaun
Posts: 5
Joined: 28 Jan 2012
Location: Calgary Canada

New mod and maps

Postby chaos_dragon2 » Jan 28 2012, 16:58

Hi all, finished my WOG mod and map after years of work and testing. Its in the process of uploading now. Mod is listed as JSR-WOG to be played with the map "Ancient Realms" that I sent with it. Have never uploaded before so hopefully they end up together in the downloads.

Mod has different scripts for many of the objects. Most are creature banks of various types, rewards etc. Some unique scripts have been written to attempt to more randomize a map, such as random locations for keymaster tents. So a map can be played over and over and will always need to be fully explored to complete. My maps are not based around storylines, but are designed for long games of exploring and endless battling. Expect the maps to take a minimum of 6 months in the game to finish.

This mod is based on WOG 3.58f, and likely incompatable with any other version. Comes with a complete folder of data/s scripts so easy to install.

"Ancient Realms" map is XL and comes in single player or team version. Lots of gates and random keymaster tent locations and iIntricate map design so exploring the map is the theme. Lots and lots of fighting. For those who like high end heroes with massive armies and lots of battles, give it a try. I welcome any feedback.

User avatar
Salamandre
Genie
Genie
Posts: 1032
Joined: 13 May 2006
Location: France
Contact:

Postby Salamandre » Jan 28 2012, 18:36

Link please :D

User avatar
chaos_dragon2
Leprechaun
Leprechaun
Posts: 5
Joined: 28 Jan 2012
Location: Calgary Canada

Postby chaos_dragon2 » Jan 28 2012, 21:30

I sent them to maps@celestialheavens. Do you have another suggestion?

User avatar
Salamandre
Genie
Genie
Posts: 1032
Joined: 13 May 2006
Location: France
Contact:

Postby Salamandre » Jan 29 2012, 1:15

Ah ok, wasn't sure, as their testing maps message is empty.

User avatar
chaos_dragon2
Leprechaun
Leprechaun
Posts: 5
Joined: 28 Jan 2012
Location: Calgary Canada

Postby chaos_dragon2 » Jan 29 2012, 2:33

Hmm ok well let me know if it doesn't show up anywhere. I can try to resend it then.Was 2 zip files. s.zip and JSR-WOG.zip

thanks

greggydion
Leprechaun
Leprechaun
Posts: 4
Joined: 30 Jan 2012

Postby greggydion » Jan 30 2012, 23:08

Lots of gates and random keymaster tent locations and iIntricate map design so exploring the map is the theme. Lots and lots of fighting.

User avatar
Salamandre
Genie
Genie
Posts: 1032
Joined: 13 May 2006
Location: France
Contact:

Postby Salamandre » Jan 31 2012, 0:05

You will need ERA II (latest wog) to be able to play this mod without conflicting or changing any of the regular data. I am a bit confused about map design, but probably will make sense when playing. Will give a try soon.

User avatar
chaos_dragon2
Leprechaun
Leprechaun
Posts: 5
Joined: 28 Jan 2012
Location: Calgary Canada

Postby chaos_dragon2 » Jan 31 2012, 1:30

All scripts in the mod were designed in and around 3.58f. Based on the settings of the JSR-WOG.dat file as the wop options, there are NO conflicts. It's very likely that later versions of WOG will likely use many of the same variables, functions etc. Therefore I strongly recommend this be played with 3.58f only. Yes the map may look confusing at first glance. Looks very hard to get around, that is the point. Players must explore the map, looking for the keymaster tents (which are in different locations each game).

User avatar
Salamandre
Genie
Genie
Posts: 1032
Joined: 13 May 2006
Location: France
Contact:

Postby Salamandre » Jan 31 2012, 2:52

The problem is that actually none of the active modders still use of have 3.58, due to harsh limitations, and also to endless bugs which can't be fixed actually.

ERA is not using other variables, but offers 100% flexibility when installing a mod. I mean, when using 3.58, we must create a backup when using your mod, because it replaces all important scripts. In ERA II, your mod goes in MODS folder, game reads from it, when done, remove, game reads again from regular. No changes, no backup.

Will be released very soon I think. I will keep you informed so you can give it a try and make your choice, if like. Also ERA is 100% compatible with all 3.58 maps done previously, of course. ERA II is based on 3.59 exe.

User avatar
chaos_dragon2
Leprechaun
Leprechaun
Posts: 5
Joined: 28 Jan 2012
Location: Calgary Canada

Postby chaos_dragon2 » Jan 31 2012, 14:12

Ok I will have to study and read up on any and all changes, ramifications etc to this new ERA. Have to make sure it will really convert ok, without putting me through a pile of extra work to rewrite all the scripts. Getting to old for that lol. For now, if anyone still has 3.58f installed, welcome to try it.

Iluvatar
Leprechaun
Leprechaun
Posts: 25
Joined: 10 Jan 2006
Location: Poland

Postby Iluvatar » Jan 31 2012, 23:30

Salamandre wrote:The problem is that actually none of the active modders still use of have 3.58, due to harsh limitations, and also to endless bugs which can't be fixed actually.

ERA is not using other variables, but offers 100% flexibility when installing a mod. I mean, when using 3.58, we must create a backup when using your mod, because it replaces all important scripts. In ERA II, your mod goes in MODS folder, game reads from it, when done, remove, game reads again from regular. No changes, no backup.

Will be released very soon I think. I will keep you informed so you can give it a try and make your choice, if like. Also ERA is 100% compatible with all 3.58 maps done previously, of course. ERA II is based on 3.59 exe.


Sorry for offtopic, but that;s bit of the news many of us are surely waiting for!


Return to “Wake of Gods”

Who is online

Users browsing this forum: No registered users and 2 guests