Bug Reports after patch 1.7

The game Might & Magic: Heroes VII, developed by Limbic Entertainment.

Moderator: Moderators

User avatar
cuc
Peasant
Peasant
Posts: 68
Joined: 06 Jan 2006
Location: Camelot

Bug Reports after patch 1.7

Postby cuc » Feb 19 2016, 11:30

Please report any bugs you enounter here.

Nothing else in this thread, just bug reports (to make it easy for the devs to read). :)

At the bottom of your bug report, you can report your computer specs: CPU, OS, RAM, graphics hardware and software.


Even when I set the game to use my laptop graphics card in the NVIDIA control panel, when I actually enter the game, the "Graphics Card" option in the game menu still shows my Intel onboard chip, without other choices.

Apparently this issue has existed since the beta test. When people turn off the onboard chip, the game would simply fail to launch.

Some report posts I saw:

Old bugs:
- When a dead unit is revived by Regeneration, it immedieately gets full health when it shouldn't;

- The actual damage of Tsunami does not benefit from Master of Magic;

- Stone Spikes deals double damage at the margins rather than the center as the description says;

- Bursting Rage and Fiery Rage issues;

- Dungeon's retaliation issues.

Issues that should be fixed but may be still present:
- Artifacts warping into a different artifact;

- Life Drain does not take effect when destroying an entire enemy stack, and only revives a dead unit when the drained HP can revive it to full health.

New bugs:
- Artifacts bought in shops on the map do not take effect until the player saved and reloaded the game;

- During combat, when a new turn begins, a hero's mana display may erroneously show a larger number than the hero actually has;

- Restarting duels removes the effect of Gathering Storm.


EDIT:
The "issues that may be still present" are probably caused by using old save files. In that case, they have indeed been fixed.
Last edited by cuc on Feb 20 2016, 4:05, edited 2 times in total.

User avatar
LordGraa
Leprechaun
Leprechaun
Posts: 43
Joined: 06 Jan 2006
Location: Prague
Contact:

Re: Bug Reports after patch 1.7

Postby LordGraa » Feb 24 2016, 13:34

BUG: Lightning Bolt + Air Knowledge II = Lightning Bolt additionally sets the target creature's Initiative to 1 for 3 turns and deals 15 to 150 Air damage to adjacent enemy units.

The "AoE" part of this spell (with AK II) is not working since 1.7
http://www.worldofheroes.cz - Czech Heroes Fansite
https://wpu.worldofheroes.cz/tsoaEN.html - H7 community DLC The Shadows over Ashan

User avatar
Alfalken
Leprechaun
Leprechaun
Posts: 43
Joined: 08 Oct 2015

Re: Bug Reports after patch 1.7

Postby Alfalken » Mar 8 2016, 7:25

Same here, been playing the Axeoth campaign on and off while doing other things.. and my game's pretty bug-free so far. Even the artifact swapping works fine! (of course, I might've jinxed it after posting this..) :disagree:

One thing I noticed is that the load times seems to get worse. Maybe it's just because my laptop got loaded with more stuff, or I've been playing other games with better, more optimized loading.. but still, it's definitely noticeable.

User avatar
Antalyan
Peasant
Peasant
Posts: 81
Joined: 04 Aug 2015

Re: Bug Reports after patch 1.7

Postby Antalyan » Mar 9 2016, 15:04

I suggest you to write all the bugs here if you have not done it before: https://docs.google.com/spreadsheets/d/ ... li=1#gid=0

This list is checked by Limbic devs.
Wryn Pendragon Umbranacer community H7 project: http://wpu.worldofheroes.cz/indexEN.html
H7 Unoffical Community Mod

User avatar
gourley4p
Pixie
Pixie
Posts: 102
Joined: 17 Oct 2014

Re: Bug Reports after patch 1.7

Postby gourley4p » Mar 9 2016, 19:28

I just finished up the Haven campaign over the weekend. I have only Ivan's scenario left before completing the vanilla content. Then I will move on to Axeoth.

My newest bug, an old one, is the No Active Hero bug. I would start round 2 or 3 of combat and not be able to attack or cast spells with my hero. Auto-combat did not resolve, and I was unable to reliably replicate the bug.

User avatar
gourley4p
Pixie
Pixie
Posts: 102
Joined: 17 Oct 2014

Re: Bug Reports after patch 1.7

Postby gourley4p » Mar 9 2016, 22:07

I don't find the list daunting at all. For example, I performed a Google search for WoW Known Issues and found this old thread. We're talking about a game that has been live for 12 years. Each new patch breaks something else. This simply is the state of gaming. Like cjlee, my options are to deal with it and play games to have as much fun as possible or stop playing them if I find it too frustrating.

User avatar
gourley4p
Pixie
Pixie
Posts: 102
Joined: 17 Oct 2014

Re: Bug Reports after patch 1.7

Postby gourley4p » Mar 15 2016, 2:29

New bug discovered as I completed the single player campaign tonight. When my centaur marauders attacked abbots, the following would happen 100% of the time.

Centaurs: Ranged attack at 100%
Abbots: Ranged counterattack
Centaurs: Move
Turn of centaurs resets
Centaurs: Ranged attack at 100%
Centaurs: Move
Centaurs: Ranged attack at Morale %
Centaurs: Move

I did not try this without moving the centaurs, but the key was to get the abbots to hit me. It would give me an extra 100% attack with my centaurs and though they had not taken any action yet.

User avatar
Pol
Admin
Admin
Posts: 9647
Joined: 29 Nov 2005
Location: IN SOMNIS VERITAS
Contact:

Re: Bug Reports after patch 1.7

Postby Pol » Apr 14 2016, 20:44

Closed, there's new patch 1.8. Please report any further bugs here.
"We made it!"
The Archives | Collection of H3&WoG files | Older albeit still useful | CH Downloads
PC Specs: A10-7850K, FM2A88X+K, 16GB-1600, SSD-MLC-G3, 1TB-HDD-G3, MAYA44, SP10 500W Be Quiet


Return to “Heroes VII”

Who is online

Users browsing this forum: No registered users and 5 guests