Sylvan Campaign 5: CPU uses more than 10minutes/turn

The new Heroes games produced by Ubisoft. Please specify which game you are referring to in your post.

Moderator: Moderators

User avatar
protput
Leprechaun
Leprechaun
Posts: 5
Joined: 31 Aug 2006
Location: Belgium

Sylvan Campaign 5: CPU uses more than 10minutes/turn

Postby protput » Aug 31 2006, 10:57

Hello,

I used the search function before posting the question but didn't find the answer I was looking for.

When playing the last Sylvan campaign, the game becomes almost unplayable after a while. The CPU takes almost more than 10 minutes between each turn.
Any idea what's wrong?

I have following PC configuration:
Win XP Pro
AMD 2.4GHz and 1024MB
ATI Radeon 9800 pro 256MB

Many thanks in advance! :D :D

User avatar
telepatic
Leprechaun
Leprechaun
Posts: 24
Joined: 17 Aug 2006
Location: Serbia

Postby telepatic » Aug 31 2006, 11:12

I havent got that far,so i dont have idea...but try open console(tilda)to see what is Al doin.... ;|

User avatar
Lady Farquad
Scout
Scout
Posts: 179
Joined: 28 Jun 2006
Location: Hispanic heaven

Postby Lady Farquad » Aug 31 2006, 17:35

If that didn't happened in previous campaigns I doubt the problem is with your pc config. Have you done anything different this time?

My pc goes slower if I use alt-tab too often (once it crashed). It also slows down in long battles (20+ turns).
Morior, ergo sum

User avatar
asandir
Round Table Hero
Round Table Hero
Posts: 15481
Joined: 06 Jan 2006
Location: The campfire .... mostly

Postby asandir » Sep 1 2006, 0:56

in addition to Lady Farquad's comments about alt+tab, there are a couple of other things, firstly, is it TEAL that is taking a long time? cause on a couple of maps it is a known thing (i hesitate to use the word bug) with teal

also there is a bit of a memory leak, not on the same level as HIV, but it is there, are you all patched up, cause this should improve things

good luck
Human madness is the howl of a child with a shattered heart.

User avatar
protput
Leprechaun
Leprechaun
Posts: 5
Joined: 31 Aug 2006
Location: Belgium

Postby protput » Sep 1 2006, 7:08

Thanks for the answers.

It never happened with the previous campaigns.

It is indeed Teal that is taking a long time per turn.
The latest patch I have installed is v1.2

If I don't find a solution, it will be impossible for me to finish the Sylvan campaign :(

User avatar
asandir
Round Table Hero
Round Table Hero
Posts: 15481
Joined: 06 Jan 2006
Location: The campfire .... mostly

Postby asandir » Sep 1 2006, 7:49

yep the ole teal problem, but never known it to take 10 minutes, used to take maybe 30 seconds to a minute for his turn to go on my campaign maps where this happened

if this is a real killer, i suggest maybe a cheat to end the map, or even a movement cheat so he doesn't get a turn
Human madness is the howl of a child with a shattered heart.

User avatar
Ketzal
Peasant
Peasant
Posts: 50
Joined: 06 Jan 2006
Location: New Jersey

Postby Ketzal » Sep 1 2006, 15:24

I have seen this happen in map 5, but only late in the scenario when Teal has a lot of resources and heros. It takes a long time deciding what to buy and where to go.

It does seem to get worse if the AI feels threatened by the presense of one of your heros.

User avatar
LordErtz
Demon
Demon
Posts: 348
Joined: 07 Jun 2006
Location: Philadelphia, PA

Postby LordErtz » Sep 1 2006, 22:11

It could be the bug with "instant travel"

We're not completely sure what causes the 5 min + computer turns.

markdel16
Leprechaun
Leprechaun
Posts: 1
Joined: 06 Jan 2006

Postby markdel16 » Sep 2 2006, 19:37

Argh, 10 minutes would be nice. I've been waiting 30 minutes now. It's still trying to do something. Here's a thread I found on UBI about it. Lots of people reporting this:

http://forums.ubi.com/eve/forums/a/tpc/ ... 9251064864

I'm assuming this was probably introuduced in 1.2.

User avatar
protput
Leprechaun
Leprechaun
Posts: 5
Joined: 31 Aug 2006
Location: Belgium

Postby protput » Sep 2 2006, 19:57

Hi,

just to let you know I finally managed to finish this campaign.
I read somewhere on another forum that if you go SW (taking the portal in the NE underground), the game will run smooth again.
And indeed, although it took me almost a whole day to get there :devious:

User avatar
Sir_Toejam
Nightmare
Nightmare
Posts: 1061
Joined: 24 Jul 2006

Postby Sir_Toejam » Sep 2 2006, 22:21

for me, the hang occured once i hit the surface after taking both castles in the underground.

I found that using the cheat code to keep giving myself movement points, that if i took the town farthest to the SW on the surface, this cleared the problem up.

nothing else i tried worked, and it wasn't due to the instant travel thing, as later turns where the AI used it had no problems at all.

It seems like the AI is trying to build or purchase something during its turn that causes the hang, but that's just a guess based on the results; there was nothing listed in the text of the AI's turn that suggested any kind of loop.

*shrug*

That mission starts off interesting, but the later it gets, the worse the AI seems to behave. By that, I mean it seems to make increasingly poor decisions about how to divide armies and resources.

Off all the missions, I think that one really needs the most work to make it acceptable.


Return to “Heroes V-VI”

Who is online

Users browsing this forum: Google [Bot] and 1 guest