MM VIII fails to start...

The role-playing games (I-X) that started it all and the various spin-offs (including Dark Messiah).

Moderator: Moderators

Ed Robinson
Peasant
Peasant
Posts: 98
Joined: 03 May 2007

MM VIII fails to start...

Postby Ed Robinson » Jul 18 2012, 11:44

I have recently attempted to load MM VIII, I had re-played MM Vi and VII. The opening screen gets to the "3D0" and freezes.

The messages follow:

DDERR_INVALIDPARAMS in file: D:\mm7Scr\MM8\MMVIII\CODE\screen16.cpp at line number: 2880

SaveGame Corrupted! Code=200 in file D:\mm7Scr\MM8\MMVIII\Code\Loadsave.cpp at line 765

Then the same message except:

Code201 Line: 776
Code202 Line: 785
Code203 Line: 794
etc...

The CD drive I am loading from is E: not D: and I have no idea how to redirect this or even if this matters.

Any thoughts? I have played this game on this machine a couple of years ago.

Thanks, Ed :(

Ed Robinson
Peasant
Peasant
Posts: 98
Joined: 03 May 2007

What worked for me...

Postby Ed Robinson » Jul 20 2012, 12:23

Can't tell you why, but, disabling hardware acceleration and running inside a window allowed me to start and run the game...

Ed

User avatar
Arret
Hunter
Hunter
Posts: 540
Joined: 12 Oct 2011

Postby Arret » Jul 20 2012, 22:21

Running graphics off software instead of directly off the graphics card fixes a lot of problems.

User avatar
GreatEmerald
CH Staff
CH Staff
Posts: 3329
Joined: 24 Jul 2009
Location: Netherlands

Postby GreatEmerald » Jul 21 2012, 16:08

And causes a lot, too. Running in a window should suffice here, I don't think you need to disable hardware acceleration. And even then, you can press Esc to skip the videos. Or disable them from MM8.ini.
That said, it's some kind of a Windows problem. Doesn't happen on XP, and I don't think it happens on Wine, either.


Return to “Might and Magic”

Who is online

Users browsing this forum: No registered users and 11 guests