Save game corruption

The role-playing games (I-X) that started it all and the various spin-offs (including Dark Messiah).

Moderator: Moderators

User avatar
Aether_Wind
Leprechaun
Leprechaun
Posts: 8
Joined: 15 Sep 2011

Save game corruption

Postby Aether_Wind » Nov 9 2011, 9:03

On my most recent run of MM7, I've gotten a strange error that seems to be save game corruption. Every time I enter Stone City, the game crashes after making an auto save. I'm playing a clean (i.e. Grayface's 1.6.1, no mods) game, and I've uninstalled-reinstalled to verify that it was not a corrupt data file. Also leading me to believe that it is save related is that my alternate save (way back at the path split) allows me to load Stone City just fine. I get the following header in the stderr/Errorlog file

Exception EAccessViolation in module mm7.exe at 000CA7B3.
Access violation at address 004CA7B3 in module 'mm7.exe'. Read of address 09192000.

Along with a long stack trace. The address is naturally different for each instance of the error, but it happens regardless of how I try to get in (I tried Lloyd's, front door, and Nighon tunnels). The only other instance I was able to find of this error was mentioned in this thread:

http://www.celestialheavens.com/forums/ ... hp?t=11029

But that was potentially related to the mod. I'd like to chalk it up to the fact that my computer was acting strangely when I saved it, but it just seems like such a bizarre symptom to only crash Stone City. Anyway, if anyone else has had this issue, or (hopefully) managed to get a solution to it, I'd be grateful for any help~

User avatar
GrayFace
Dragon
Dragon
Posts: 1453
Joined: 29 Nov 2005

Postby GrayFace » Nov 11 2011, 2:46

I'll check the error, but I'll need the ErrorLog.txt and the save game.
My patches: MM6 MM7 MM8. MMExtension. Tools. Also, I love Knytt Stories and Knytt Underground. I'm also known as sergroj.

User avatar
Aether_Wind
Leprechaun
Leprechaun
Posts: 8
Joined: 15 Sep 2011

Postby Aether_Wind » Nov 21 2011, 3:33

Well, I figured out that it was most likely due to bad RAM. Shortly after I posted, pretty much everything I had was crashing, so I did a memtest and found out about it. I'm guessing it was something in memory that was supposed to be written that was corrupted because of that. I restarted a new game and haven't had that problem on the new game.

User avatar
UndeadHalfOrc
Cyber Zombie
Cyber Zombie
Posts: 1362
Joined: 13 Mar 2007

Postby UndeadHalfOrc » Nov 21 2011, 12:36

I've had a few crashes in MM8 myself last game, constantly after entering naga vaults.

I switched to software 3d and it solved the problem with that dungeon.


Return to “Might and Magic”

Who is online

Users browsing this forum: Xfing and 13 guests